Rename Validator#forMethods() to forExecutables()

Description

In the metadata API we use the terminus "Executable" when referring to methods and constructors. For the sake of consistence we should thus rename Validator#forMethods() to forExecutables() and MethodValidator to ExecutableValidator.

Discussion: https://lists.jboss.org/pipermail/beanvalidation-dev/2013-January/000710.html

Environment

None

Assignee

Gunnar Morling

Reporter

Gunnar Morling

Labels

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Suitable for new contributors

None

Pull Request

None

backportDecision

None

backportReEvaluate

None

Components

Fix versions

Affects versions

Priority

Major
Configure