Upgrade to Infinispan 8

Description

As agreed on the face to face meeting, Hibernate ORM should drop backwards compatibility with Infinispan 7 since 5.1. The hibernate-infinispan module will require Infinispan 8.+.

N.B. this module will require Java 8, but this requirement should not creep in the other modules.

Environment

None

Status

Assignee

Radim Vansa

Reporter

Sanne Grinovero

Fix versions

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Priority

Major
Configure