We're updating the issue view to help you get more done. 

Migrate HikariCP from Java 1.6 to Java 1.8

Description

Currently, we are using:

1 "com.zaxxer:HikariCP-java6:2.3.9"

This is a Java 1.6 dependency which does not implement on top of JDBC 4.1 (Java 1.7) and JDBC 4.2 (Java 1.8).

Since Hibernate ORM 5.2 already uses Java 1.8, it's time to upgrade to the default HikariCP version which is based on Java 1.8:

1 "com.zaxxer:HikariCP:2.5.1"

Environment

None

Status

Assignee

Vlad Mihalcea

Reporter

Vlad Mihalcea

Components

Fix versions

Affects versions

5.2.3

Priority

Major