Mainly this is to pull out the caching SPI changes proposed on  into its own Jira.
If we end up implementing these other changes, here are some others ideas I'd like to do at the same time (but not really worth making on their own):
Rename org.hibernate.cache.spi.access.RegionAccessStrategy to just RegionAccess. IMO the "Strategy" part adds no value. Similarly, renames its specializations:
org.hibernate.cache.spi.access.EntityRegionAccessStrategy -> EntityRegionAccess.
Remove the various #toMap methods