Revert to using the Javassist version included in WildFly 11

Description

Since Hibernate required a Javassist version significantly higher than what is included in WildFly, to run integration tests we bundled an "override" version of Javassist to use our version of Javassist rather than the one in WildFly.

The version in WildFly 11 is now slightly out of date compared to the one being used by Hibernate ORM but it appears to be compatible, so when running integration tests I'd switch to use the application server provided version as this avoids some trouble in JDK9 related tests.

Incidentally this also simplifies the packaging requirements of end users: they no longer need to explicitly exclude the javassist module from the server, so it's a good usability improvement.

Environment

None

Assignee

Sanne Grinovero

Reporter

Sanne Grinovero

Fix versions

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Priority

Major
Configure