Hibernate-orm-module-5.2.X for wildfly 10

Description

We need a hibernate orm modules for wildfly 10, but there is only one for wildfly 11 on maven central. We have test it on widlfly 10, it not work. The type of proxy of entity seems to be changed.

Environment

wildfly 10.1.0.Final

Activity

Show:
Gail Badner
January 30, 2018, 11:23 PM

According to https://docs.jboss.org/hibernate/orm/5.2/topical/html_single/wildfly/Wildfly.html:

"Our goal is to provide a module ZIP file targeted at the WildFly version current at the time of the Hibernate release (e.g. WildFly 10 for Hibernate ORM 5.1.x and up until 5.2.10, as well as WildFly 11 since Hibernate ORM 5.2.11)."

Are you trying a version that is more recent than 5.2.10? If so, that is not supported with WildFly 10.

Gail Badner
January 30, 2018, 11:35 PM

Also in https://docs.jboss.org/hibernate/orm/5.2/topical/html_single/wildfly/Wildfly.html, see the section, "Avoiding outdated Javassist versions from WildFly":

Does that resolve your issue?

Xj Chen
January 31, 2018, 6:55 PM

Yes. But updating an entire server has a much bigger impact than updating a single module. Since Hibernate is a highly independent library, it should not have too much coupling to the server

Gail Badner
January 31, 2018, 7:37 PM

This is a known limitation.

Assignee

Gail Badner

Reporter

Xj Chen

Fix versions

None

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Affects versions

Priority

Major
Configure