We're updating the issue view to help you get more done. 

Update README and migration notes to indicate changes in Java compatibility in 5.1 branch

Description

The following changed Java compatibility to 1.7:

  • In 5.1.4, java.util.Objects was introduced by an unused import statement into ActionQueue by HHH-9864. This seemed to only affect only some versions of Java 1.6.

  • In 5.1.11, java.util.regex.Pattern.UNICODE_CHARACTER_CLASS was introduced into ReflectHelper by HHH-11377.

The following changed Java compatibility to 1.8:

  • In 5.1.17, the upgrade to dom4j to 2.2.1 by HHH-12964.

The README and migration notes should reflect these changes.

Environment

None

Status

Assignee

Gail Badner

Reporter

Gail Badner

Labels

None

Worked in

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Community Help Wanted

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

backportReEvaluate

None

Fix versions

Priority

Major