Hibernate 5.1 no longer runs on Java 1.6 or 1.7

Description

Because it uses the Dpm4J dependency 2.1.1, running a Hibernate 5.1 application on Java 1.6 or 1.7 is no longer possible since the Dom4J dependency was built with Java 1.8.

The only way it works is if the Dom4J dependency is switched to 2.0.2 or below.

Environment

None

Status

Assignee

Gail Badner

Reporter

Vlad Mihalcea

Fix versions

None

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Affects versions

Priority

Major
Configure