build Wiki has a typo and includes a lie re:jdk version

Description

See here: http://hibernate.org/6.html#A6
"Compiling Hibernate

Run build.xml with Ant under JDK 1.2 or later (JKD 1.4 required"

Should be JDK 1.4 required

However actually "or later" is an error http://opensource.atlassian.com/projects/hibernate/browse/HHH-2446 as JDK 6+ cannot be used to build.

"You need to use JDK 5.0 or later" is said for Hibernate Annotations, but I cannot evaluate the statement by itself nor would it likely be very fun to have H3 compiled into JDK5 classes and H3A in JDK6...

It should be corrected to prevent lots of duplicate JIRA bugs saying "I followed the instructions but H3 doesn't compile!"

Environment

None

Activity

Show:
Diego Plentz
August 12, 2008, 10:59 PM

Thanks.

Assignee

Diego Plentz

Reporter

Andrew C. Oliver

Fix versions

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Affects versions

Priority

Minor
Configure