Hibernate cannot be built with JDK 1.4, nor with JDK 1.6

Description

Despite the fact that Hibernate officially requires JRE 1.4 only, it cannot be built from sources using JDK 1.4.
There is a restriction enforced in a Maven configuration file upon the building JDK version, namely at least 1.5 is required. Removing this restriction yields some JUnit test errors for JBoss cache.
Conversely, Hibernate cannot be built with JDK 1.6 since JDBC 4.0 adds some new methods that Hibernate is not aware of and the compilation fails.

The solution is:

  • not to build JBoss(2) cache when the building JDK is 1.4 (already missing Ant ?)

  • to account for the new methods introduced in JDBC 4.0 (even if they are not needed they must be implemented)

Environment

None

Activity

Show:
Andra Nedelcovici
September 9, 2008, 3:13 PM

Where it is written that HIbernate must be built with JDK 1.5? Officially, Hibernate requires JRE 1.4. Why should 1.5 be necessary for building?

Moreover, this bug duplicates only partially.

Gail Badner
September 9, 2008, 12:02 AM

Hibernate 3.3 must be built using at least JDK 1.5.

Currently, it is not buildable using 3.3, but that is covered in HHH-2412.

Duplicate

Assignee

Gail Badner

Reporter

Andra Nedelcovici

Fix versions

None

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

Affirmative

Pull Request

None

backportDecision

None

Components

Affects versions

Priority

Critical