Slight naming changes in regards to new logging classes

Description

2 aspects:

  1. Rename these to not use the term "Logger" since they really are not loggers. For example HibernateLogger -> Core18nMessages (core because its the one for the hibernate-core module

  2. we need to move these out of the public api packages. internal makes much more sense.

Environment

None

Status

Assignee

Steve Ebersole

Reporter

Steve Ebersole

Fix versions

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Affects versions

4.0.0.Alpha2

Priority

Major