DerbyDialect is not backward compatible

Description

I moved from 3.3.2 to 3.5.6 so I don't know when exactly this has been changed. In DerbyDialect there used to be the TableHiLoGenerator which is now commented out. When running on a DB that was created with SchemaGenerator from earlier releases the new Dialect gives ConstraintVialoations as the old ID columns are not of type identity. I could work around by sublassing DerbyDialect and implement the Genrator again.

Environment

Latest Derby, Core 3.5.6

Activity

Show:
Brett Meyer
October 2, 2013, 2:21 PM

DerbyDialect is deprecated by DB2Dialect. Is there still an issue there?

Assignee

Unassigned

Reporter

ThomasK

Fix versions

None

Labels

None

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Affects versions

Priority

Trivial
Configure