We're updating the issue view to help you get more done. 

Move to Gradle 1.3

Description

The git://github.com/hibernate/hibernate-orm.git project will not build using Gradle 1.3. Tasks :hibernate-core:generateMainLoggingClasses and :hibernate-envers:generateJpaMetamodelClasses fail:

1 2 3 4 5 6 7 8 9 10 11 12 :hibernate-core:generateMainLoggingClasses FAILED FAILURE: Build failed with an exception. * What went wrong: A problem was found with the configuration of task ':hibernate-core:generateMainLoggingClasses'. > No value has been specified for property 'dependencyCacheDir'. * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. BUILD FAILED

README.md does not mention a Gradle version dependency and uses 'gradle' and 'gradlew' interchangeably which is a bit misleading.

Environment

------------------------------------------------------------ Gradle 1.3
------------------------------------------------------------
Gradle build time: den 20 november 2012 kl 11:37 UTC
Groovy: 1.8.6
Ant: Apache Ant(TM) version 1.8.4 compiled on May 22 2012
Ivy: 2.2.0
JVM: 1.7.0-jdk7u4-b19 (Oracle Corporation 23.0-b20)
OS: Mac OS X 10.7.5 x86_64

Status

Assignee

Unassigned

Reporter

Jörgen Rydenius

Fix versions

None

Labels

backPortable

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

Components

Affects versions

4.1.9

Priority

Minor