We're updating the issue view to help you get more done. 

Auto-detect SQL Server 2014 when the major version is 12

Description

Please add support for SQL Server 20014.

When trying to autodetect the best dialect to use, we recieve this error:

[code]WARN StandardDialectResolver - HHH000385: Unknown Microsoft SQL Server major version [12] using SQL Server 2000 dialect – [code]

Also if possible, please add a bit of logic where Hibernate does a graceful downgrade to latest known dialect (eg. SQL2012Dialect) if the dabase major version is larger than the current highest known version, so it doesn't revert to lowest common version.

Environment

SQL Server 2014

Status

Assignee

Vlad Mihalcea

Reporter

Jens Dueholm Christensen

Labels

Components

Fix versions

Affects versions

4.3.8

Priority

Major