While reviewing HSEARCH-1222 Closed I stumbled upon a few things that I am not happy with yet:
- @Spatial on a class without Spatial.name means that the Lucene document field prefix is the fully qualified class name. I don't think that's a correct value
- SpatialMode.SIMPLE is not descriptive as a name, I'd rather have SpatialModel.RANGE
- the reference doc is incomplete compared to the feature options we offer
Back to issue 2, is there even a good default value in this case? @ClassBridge has a default value for name but that looks like a mistake as well.