We currently have 2 classes which represent a range facet:
FacetRange: used by the DSL to build a facet range query
RangeFacet: an interface to represent a facet range query
RangeFacet contains isIncludeMin and isIncludeMax whereas FacetRange contains isMinIncluded and isMaxIncluded.
It would be better if the naming was consistent.