Uploaded image for project: 'Hibernate Search'
  1. HSEARCH-2312

Do not require the lucene-backward-codecs dependency

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.6.0.Beta2
    • Component/s: engine
    • Labels:
      None

      Description

      There is no reason to mandate the lucene-backward-codecs dependency.

      We do package it as a private dependency in the JBoss Modules, as otherwise it would be hard to let Lucene load it from users classpath but we don't need it as a dependency of the hibernate-search-engine Maven artifact.

      I could flag it as "optional" but since we don't need it at compile time either - which is the purpose of the optional flag - I'll just remove the dependency.

        Attachments

          Activity

            People

            • Assignee:
              sanne Sanne Grinovero
              Reporter:
              sanne Sanne Grinovero
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: