Add Elasticsearch compatibility policy to the documentation and/or website

Description

Support only 5.6 and later.
In the future:

  • We keep compatibility with older ES version as long as it’s practical

  • When some changes require to drop support for an older ES version, we do it in a new minor version of Search

  • We advertise some minor versions of Hibernate Search as “LTS”, to allow people to stay on older versions of ES while still receiving critical patches.

[Openshift version of ES is tracked here: https://github.com/openshift/origin-aggregated-logging/blob/master/elasticsearch/Dockerfile ]

Environment

None

Status

Assignee

Unassigned

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Pull Request

None

Feedback Requested

None

Components

Fix versions

Priority

Major
Configure