We're updating the issue view to help you get more done. 

Add dependency management for Jackson-databind and upgrade to the latest version

Description

The Elasticsearch REST Sniffer is not using the latest versions, there there has been a lot of CVEs on the currently used versions. I'm not sure they are relevant to our usage, but let's not take any risk and upgrade if possible.

Ideally, we should also send a PR upstream for the Elasticsearch REST Sniffer to upgrade their dependency.
See here: https://github.com/elastic/elasticsearch/blob/master/buildSrc/version.properties#L7

CC

Environment

None

Status

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Pull Request

None

Feedback Requested

None

Components

Priority

Major