Search 6 groundwork - Rename Search.getSearchSession(Session) to Search.session(Session)

Description

This:

will become this:

... which is shorter but also will allow, one day, to have extra methods in Search such as this:

Keep Search.getSearchSession() for now, but implement it as a redirection to Search.session(), and deprecate it.

Be sure to replace every use of Search.getSearchSession() in our code with the new syntax.

Environment

None

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Feedback Requested

None

Components

Fix versions

Priority

Major
Configure