Rename fetch()/fetchHits() methods in Query APIs to fetchAll/fetchAllHits

Description

So that it's clearer that we will fetch all the hits, which is generally a bad idea.

We may want to also rename the methods with offsets to fetchAfter(int offset, Integer limit), to make them more distinguishable from fetch(Integer limit), and prepare the introduction of fetchAfter(SearchSortKey key, Integer limit), which will allow more efficient paging when not sorting by score.

Let's keep deprecated methods for now.

Environment

None

Status

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Feedback Requested

None

Components

Fix versions

Priority

Major
Configure