Remove "get"/"set" prefixes from API methods

Description

We sometimes use a "get"/"set" prefix (SearchResult.getHits(), PropertyBindingContext.setBridge(...), ...), but most of the time we don't (Search.session(...), IndexManager.descriptor(), various DSLs that don't use "set", ...).

I think we should be consistent and not use the prefixes anywhere, for the sake of consistency and brevity. JavaBeans or JPA entity conventions don't apply here, as we're not talking about JavaBeans nor JPA entities.

Old methods with the prefixes should be kept as deprecated for now, of course. There shouldn't be many of them.

Environment

None

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Feedback Requested

None

Fix versions

Priority

Major
Configure