Rename ObjectFieldStorage to ObjectStructure and move it to a more appropriate package

Description

It's currently in a "dsl" package, unlike similar enums such as org.hibernate.search.engine.backend.types.Projectable. Maybe move it to that package? Or to org.hibernate.search.engine.backend.document.model?

This may also be an opportunity to rename this concept to ObjectStructure, which is arguably more fitting.
If we did, we could just deprecate the old enum and corresponding annotation attributes/DSL methods in the mapping.

Environment

None

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Feedback Requested

None

Fix versions

Priority

Major
Configure