Remove OSGi and Wildfly support and integration tests from legacy code

Description

  1. we're not going to restore support for OSGi/WildFly in 6.0.0.Final

  2. when (if) we restore support, we'll probably use different ways to define the modules (Galleon: https://docs.wildfly.org/galleon/)

  3. when (if) we restore support, existing tests will be obsolete since they rely on Search 5 APIs

  4. in the meantime, these modules and tests are getting in the way of changes to the build, in particular to use JDK11 as a default.

Environment

None

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Pull Request

None

Feedback Requested

None

Components

Fix versions

Affects versions

Priority

Major
Configure