Recommend specifying a Lucene compatibility version in configuration

Description

We should clearly state that specifying a Version is recommended, and log a warning if it's not done.
Also make sure we run the testsuite on the same version as we default to.

See also http://lists.jboss.org/pipermail/hibernate-dev/2011-July/006735.html

Environment

None

Status

Assignee

Unassigned

Reporter

Sanne Grinovero

Labels

None

Suitable for new contributors

Yes, likely

Pull Request

None

Feedback Requested

None

Components

Fix versions

Priority

Trivial
Configure