Uploaded image for project: 'Hibernate Validator'
  1. HV-1460

Remove the Maven version prerequisite as it's redundant with the enforcer configuration and now generates a warning

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 6.0.1.Final
    • Component/s: build
    • Labels:
      None

      Description

      We have a new warning in the build with Maven 3.5.0:
      [WARNING] The project org.hibernate.validator:hibernate-validator-parent:pom:6.0.1-SNAPSHOT uses prerequisites which is only intended for maven-plugin projects but not for non maven-plugin projects. For such purposes you should use the maven-enforcer-plugin. See https://maven.apache.org/enforcer/enforcer-rules/requireMavenVersion.html

        Attachments

          Activity

            People

            • Assignee:
              gsmet Guillaume Smet
              Reporter:
              gsmet Guillaume Smet
              Participants:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: