Update JavaMoney dependency to MR1 of JSR354

Description

The dependencies for JavaMoney are currently

  • 1.0.1 (API)

  • 1.1 (Moneta RI)

Both were updated in the last few weeks to

  • 1.1 (API)

  • 1.4.1 (Moneta RI)

Although Moneta 1.3 and above are modular, a BOM with the identical Maven coordinates as the earlier JAR module makes upgrading it rather easy and especially the API is fairly backward-compatible, so it could be in the interest to support the Maintenance Release 1 of JSR 354 because it also resolved the license issues earlier API versions before 1.1 had.

I'm not sure about a backport, I leave that to you, especially the upcoming 7.x releases should consider it, earlier versions may benefit from the license resolution, but it may not be that crucial.

Environment

None

Activity

Show:
Werner Keil
July 24, 2020, 1:10 PM
Edited

Also see the announcement in https://groups.io/g/javamoney/message/25, we hope to have Moneta 1.4.2 with the original configuration functionality while offering the new Provider as a “preview” to play with soon.

Werner Keil
July 28, 2020, 7:51 AM
Edited

Moneta 1.4.2 was released reverting the config experiments that did not seem ready for all environments.

Would you be able to test this version in Wildfly?

Guillaume Smet
July 28, 2020, 3:44 PM

thanks! I'm giving it a try here: https://github.com/hibernate/hibernate-validator/pull/1118 .

We will see how CI goes.

Werner Keil
August 4, 2020, 12:46 PM

How did it go?

Werner Keil
August 8, 2020, 7:37 PM

Maybe you’re on vacation, hope to hear, how the CI worked, or can we see the result somewhere?

Assignee

Guillaume Smet

Reporter

Werner Keil

Labels

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Suitable for new contributors

None

backportDecision

Undecided

backportReEvaluate

None

Components

Priority

Major
Configure