We're updating the issue view to help you get more done. 

Hibernate Validator doesn't compile under OpenJDK 6

Description

1 2 3 /qa/hudson_ws/workspace/hibernate-validator-trunk/jdk/openjdk-local/label/RHEL5_any/trunk/hibernate-validator/src/test/java/org/hibernate/validator/util/TestUtil.java:[66,30] incompatible types; inferred type argument(s) java.lang.Object do not conform to bounds of type variable(s) T found : <T>javax.validation.bootstrap.ProviderSpecificBootstrap<T> required: java.lang.Object

Environment

RHEL5, OpenJDK6

Status

Assignee

Unassigned

Reporter

Juraci Paixão Kröhling

Labels

None

Worked in

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Community Help Wanted

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

backportReEvaluate

None

Components

Priority

Major