Enable enforcer maven plugin for Neo4j

Description

It was disable because the Lucene version in Neo4j was different from the one used by Hibernate Search, now the tow versions are aligned and we should take advantage of it for as long as we can.

Enabling the plugin will allow us to keep track when the compatibility will end.

Environment

None

Assignee

Davide D'Alto

Reporter

Davide D'Alto

Labels

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Suitable for new contributors

None

backportDecision

None

backportReEvaluate

None

Components

Fix versions

Priority

Major
Configure