Support JDK->= 11

Description

Add build profile to support JDK >= 11. In JDK 9, some APIs got declared as deprecated, including javax.xml.bind. From version 11 onwards, these APIs got removed from the JDK. Utilization requires an explicit dependency declaration.

Environment

None

Assignee

Markus Gritsch

Reporter

Markus Gritsch

Labels

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Suitable for new contributors

None

backportDecision

None

backportReEvaluate

None

Components

Fix versions

Affects versions

Priority

Minor
Configure