Editing a post in preview mode creates errors in split_cloud.html.haml

Description

When editing a post while previewing the site, the re-generation kicks in and generates errors of the form:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 no implicit conversion of nil into String Rendering file /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml resulted in a failure. Line: unknown Backtrace: /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:9:in `+' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:9:in `block (2 levels) in singleton class' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:7:in `each' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:7:in `block in singleton class' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:-7:in `instance_eval' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:-7:in `singleton class' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/_ext/split_cloud.html.haml:-9:in `__tilt_70227434639500' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/tilt-2.0.1/lib/tilt/template.rb:155:in `call' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/tilt-2.0.1/lib/tilt/template.rb:155:in `evaluate' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/tilt-2.0.1/lib/tilt/haml.rb:17:in `evaluate' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/tilt-2.0.1/lib/tilt/template.rb:96:in `render' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/handlers/base_tilt_handler.rb:135:in `rendered_content' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/handlers/layout_handler.rb:47:in `rendered_content' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/page.rb:143:in `rendered_content' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/engine.rb:285:in `generate_page' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/engine.rb:392:in `generate_page_internal' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/engine.rb:384:in `block in run_auto_for_non_page' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/engine.rb:383:in `each' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/engine.rb:383:in `run_auto_for_non_page' /Users/hardy/work/hibernate/git/in.relation.to/in.relation.to/.bundle/ruby/2.0.0/gems/awestruct-0.5.5/lib/awestruct/cli/auto.rb:58:in `block (3 levels) in run'

Should we even enable re-generation per default?

Environment

None

Status

Assignee

Unassigned

Reporter

Hardy Ferentschik

Labels

None

Worked in

None

Feedback Requested

None

Feedback Requested By

None

backPortable

None

Community Help Wanted

None

Suitable for new contributors

None

Requires Release Note

None

Pull Request

None

backportDecision

None

backportReEvaluate

None

Components

Priority

Major