We're updating the issue view to help you get more done. 

Review package naming in the new ElasticSearch integration module

Description

Currently the main package is named org.hibernate.search.backend.elasticsearch, which seems ok as long as we think of it as "just another backend".

But it does expose other things like Query helpers too, for example the Projection constants needed are now exposed as:

org.hibernate.search.backend.elasticsearch.ProjectionConstants (extending org.hibernate.search.engine.ProjectionConstants)

I feel that makes it more than a backend, so we should discuss this. My proposal is to just go with org.hibernate.search.elasticsearch.* as main root.

Environment

None

Status

Assignee

Sanne Grinovero

Reporter

Sanne Grinovero

Components

Fix versions

Priority

Blocker