Document the supported Elasticsearch versions in the reference documentation

Description

I couldn't find this piece of information in the reference documentation.

As for the wording, we might not want to say "supported versions", because it's still a technical preview, but we might at least state what versions are expected to work.

A version range should be given, i.e. the oldest version expected to work and the newest tested version.

Environment

None

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Pull Request

None

Feedback Requested

None

Fix versions

Affects versions

Priority

Major
Configure