Re-brand the "ram" DirectoryProvider as "local-heap"

Description

To make it clear that the only reasonable usage of the RAMDirectory is to run quick integration testing, it was suggested that we change its name and clarify this purpose in the documentation.

After a quick poll on the mailing list my favourite choice is "testing".

Activity

Show:

Sanne GrinoveroMay 19, 2017 at 9:50 AM

The debate on the mailing list was quite active. People don't seem to like "testing", my favourite alternative is "local-heap" which seems to be a good compromise.

I'd still want to make the documentation clear about this only being suggested for testing purposes.

Fixed

Details

Assignee

Reporter

Fix versions

Priority

Created May 18, 2017 at 8:36 PM
Updated June 13, 2017 at 10:38 AM
Resolved June 8, 2017 at 11:16 PM

Flag notifications