Manage the version of Jackson to the latest available version

Description

It's only used in the Elasticsearch Sniffer, but they are unwilling to upgrade for some reason related to the Elasticsearch core (which isn't relevant to us).

Let's manage it and upgrade.

This might impact users that have both Hibernate Search and the High-level Elasticsearch client in their classpath, so this should be done in 6.x only, and we'll do in in 5.12 if it is ever released.

Environment

None

Status

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Feedback Requested

None

Components

Fix versions

Priority

Major
Configure