Switch to a more accessible wording:
asProjection(...) -> select( … )
asEntity() -> selectEntity()
asEntityReference() -> selectEntityReference()
predicate(...) -> where(...)
The point is to have examples more easily understood by new users reading blog posts, the documentation, etc.
The scope methods (scope.predicate(), ...) should not change: those refer to the type of object they allow to build, so their current name is appropriate.
We will keep the old methods, but deprecate them.
We will keep them for a long time, probably until the last betas.
We will need to update:
We will need to explain the reasons for this change in the release blog post.