Rename @IndexedEmbedded.maxDepth to includeDepth

Description

Because this more clearly conveys the purpose of that attribute: embedding fields up to that depth.

Still not crystal-clear, but at least it's not as confusing as "depth" (of what?) "maxDepth" (it's not the max, you can include fields beyond that depth).

Maybe keep the old syntax as deprecated, for now.

Environment

None

Assignee

Yoann Rodière

Reporter

Yoann Rodière

Labels

None

Suitable for new contributors

None

Feedback Requested

None

Components

Fix versions

Priority

Major
Configure