Bump dependency to core 3.5.1-Final

Description

The release pom should suggest a dependency to core version 3.5.1 , but it would be nice to start defining support for ranges of versions.
I'd propose something like <version>[3.5.0,3.6.0)</version> but have to try to see how this interacts with the .FINAL postfix

Environment

None

Status

Assignee

Unassigned

Reporter

Sanne Grinovero

Labels

None

Suitable for new contributors

None

Pull Request

None

Feedback Requested

None

Fix versions

Priority

Trivial
Configure